$re = '/[^\w.-]/';
$str = 'A\\\'skljdsg\\\\\\sk//dgj@@@////#``flkl_dfd-_-sfsfs-fk kgj.docx';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;