#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^\w.-]"
Local $sString = "A\'skljdsg\\\sk//dgj@@@////#``flkl_dfd-_-sfsfs-fk kgj.docx"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)