import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "xsi:schemaLocation=\\\"http:\\/\\/www\\.hello\\.org\\/abcss-4_2 http:\\/\\/www\\.hello\\.org\\/v4-2\\/abcss-4-2\\.xsd\\\"";
final String string = "<Hello version=\"100\" xmlns=\"http://www.hello.org/abcss-4_2\" xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\" xsi:schemaLocation=\"http://www.hello.org/abcss-4_2 http://www.hello.org/v4-2/abcss-4-2.xsd\">";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}