$re = '/xsi:schemaLocation=\"http:\/\/www\.hello\.org\/abcss-4_2 http:\/\/www\.hello\.org\/v4-2\/abcss-4-2\.xsd\"/';
$str = '<Hello version="100" xmlns="http://www.hello.org/abcss-4_2" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.hello.org/abcss-4_2 http://www.hello.org/v4-2/abcss-4-2.xsd">';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);