const regex = /xsi:schemaLocation=\"http:\/\/www\.hello\.org\/abcss-4_2 http:\/\/www\.hello\.org\/v4-2\/abcss-4-2\.xsd\"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('xsi:schemaLocation=\\"http:\\\/\\\/www\\.hello\\.org\\\/abcss-4_2 http:\\\/\\\/www\\.hello\\.org\\\/v4-2\\\/abcss-4-2\\.xsd\\"', '')
const str = `<Hello version="100" xmlns="http://www.hello.org/abcss-4_2" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.hello.org/abcss-4_2 http://www.hello.org/v4-2/abcss-4-2.xsd">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}