import Foundation
let pattern = #"xsi:schemaLocation=\"http:\/\/www\.hello\.org\/abcss-4_2 http:\/\/www\.hello\.org\/v4-2\/abcss-4-2\.xsd\""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<Hello version="100" xmlns="http://www.hello.org/abcss-4_2" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.hello.org/abcss-4_2 http://www.hello.org/v4-2/abcss-4-2.xsd">"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}