package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https:\/\/[^\/]*\/e\/([^\/]*).*`)
var str = `https://10.111.24.145/e/f6850485-4e5d-4700-bb7c-70165449479d/#dashboard;gtf=l_2_HOURS;gf=-4143820502672292577;id=7936f4d6-04af-4d63-8b3d-37c52f84570b`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}