const regex = /https:\/\/[^\/]*\/e\/([^\/]*).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/[^\\\/]*\\\/e\\\/([^\\\/]*).*', 'gm')
const str = `https://10.111.24.145/e/f6850485-4e5d-4700-bb7c-70165449479d/#dashboard;gtf=l_2_HOURS;gf=-4143820502672292577;id=7936f4d6-04af-4d63-8b3d-37c52f84570b`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}