import re
regex = re.compile(r"https:\/\/[^\/]*\/e\/([^\/]*).*", flags=re.MULTILINE)
test_str = "https://10.111.24.145/e/f6850485-4e5d-4700-bb7c-70165449479d/#dashboard;gtf=l_2_HOURS;gf=-4143820502672292577;id=7936f4d6-04af-4d63-8b3d-37c52f84570b"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")