import Foundation
let pattern = #"https:\/\/[^\/]*\/e\/([^\/]*).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"https://10.111.24.145/e/f6850485-4e5d-4700-bb7c-70165449479d/#dashboard;gtf=l_2_HOURS;gf=-4143820502672292577;id=7936f4d6-04af-4d63-8b3d-37c52f84570b"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)