re = /https:\/\/[^\/]*\/e\/([^\/]*).*/m
str = 'https://10.111.24.145/e/f6850485-4e5d-4700-bb7c-70165449479d/#dashboard;gtf=l_2_HOURS;gf=-4143820502672292577;id=7936f4d6-04af-4d63-8b3d-37c52f84570b'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end