#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d*(?:\.\d+)?(?:(?<=\d)[^.\d\n]+\.)?$"
Local $sString = ".12345." & @CRLF & _
".12345" & @CRLF & _
" <-- error: erroneous numeral." & @CRLF & _
".12345(." & @CRLF & _
"' or '" & @CRLF & _
".12345*." & @CRLF & _
"' <-- Good."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")