re = /^\d*(?:\.\d+)?(?:(?<=\d)[^.\d\n]+\.)?$/m
str = '.12345.
.12345
<-- error: erroneous numeral.
.12345(.
\' or \'
.12345*.
\' <-- Good.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end