using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d*(?:\.\d+)?(?:(?<=\d)[^.\d\n]+\.)?$";
string input = @".12345.
.12345
<-- error: erroneous numeral.
.12345(.
' or '
.12345*.
' <-- Good.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}