const regex = /^\d*(?:\.\d+)?(?:(?<=\d)[^.\d\n]+\.)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d*(?:\\.\\d+)?(?:(?<=\\d)[^.\\d\\n]+\\.)?$', 'gm')
const str = `.12345.
.12345
<-- error: erroneous numeral.
.12345(.
' or '
.12345*.
' <-- Good.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}