$re = '/^\d*(?:\.\d+)?(?:(?<=\d)[^.\d\n]+\.)?$/m';
$str = '.12345.
.12345
<-- error: erroneous numeral.
.12345(.
\' or \'
.12345*.
\' <-- Good.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);