using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z])ss$";
string substitution = @"\1SS";
string input = @"Klasse, STRAssE, FUss";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}