const regex = /([A-Z])ss$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z])ss$', 'g')
const str = `Klasse, STRAssE, FUss`;
const subst = `\1SS`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);