$re = '/([A-Z])ss$/';
$str = 'Klasse, STRAssE, FUss';
$subst = "\1SS";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;