import Foundation
let pattern = #"([A-Z])ss$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Klasse, STRAssE, FUss"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1SS"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)