use strict;
my $str = 'Klasse, STRAssE, FUss';
my $regex = qr/([A-Z])ss$/p;
my $subst = '\\1SS';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";