#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(start((?!start).)*?end)"
Local $sString = "start spam" & @CRLF & _
"start rubbish" & @CRLF & _
"start wait for it..." & @CRLF & _
" profit!" & @CRLF & _
"here end" & @CRLF & _
"start garbage" & @CRLF & _
"start second match" & @CRLF & _
"win. end"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")