import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(start((?!start).)*?end)";
final String string = "start spam\n"
+ "start rubbish\n"
+ "start wait for it...\n"
+ " profit!\n"
+ "here end\n"
+ "start garbage\n"
+ "start second match\n"
+ "win. end";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}