#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^http:\/\/myanimelist\.net\/animelist\/(.*[^\/])(?:\/|)$"
Local $sString = "http://myanimelist.net/animelist/YOURUSERNAME"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")