re = /^http:\/\/myanimelist\.net\/animelist\/(.*[^\/])(?:\/|)$/
str = 'http://myanimelist.net/animelist/YOURUSERNAME'
# Print the match result
str.match(re) do |match|
puts match.to_s
end