$re = '/^http:\/\/myanimelist\.net\/animelist\/(.*[^\/])(?:\/|)$/';
$str = 'http://myanimelist.net/animelist/YOURUSERNAME';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);