using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^http:\/\/myanimelist\.net\/animelist\/(.*[^\/])(?:\/|)$";
string input = @"http://myanimelist.net/animelist/YOURUSERNAME";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}