# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b[\w\d_\-]+\b\\//...\//g;t' <<< "p := some/path/to/file
p := so_me/pa-th/to/file
p := so_me/mo-re/pat_hs/to_your/file
p := som3/m0_r3/pa7h-5/t0_/y0ur/file"