const regex = /\b[\w\d_\-]+\b\//g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[\\w\\d_\\-]+\\b\\\/', 'g')
const str = `p := some/path/to/file
p := so_me/pa-th/to/file
p := so_me/mo-re/pat_hs/to_your/file
p := som3/m0_r3/pa7h-5/t0_/y0ur/file`;
const subst = `.../`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);