import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[\\w\\d_\\-]+\\b\\/";
final String string = "p := some/path/to/file\n"
+ "p := so_me/pa-th/to/file\n"
+ "p := so_me/mo-re/pat_hs/to_your/file\n"
+ "p := som3/m0_r3/pa7h-5/t0_/y0ur/file";
final String subst = ".../";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}