$re = '/\b[\w\d_\-]+\b\//';
$str = 'p := some/path/to/file
p := so_me/pa-th/to/file
p := so_me/mo-re/pat_hs/to_your/file
p := som3/m0_r3/pa7h-5/t0_/y0ur/file';
$subst = ".../";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;