package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[\w\d_\-]+\b\/`)
var str = `p := some/path/to/file
p := so_me/pa-th/to/file
p := so_me/mo-re/pat_hs/to_your/file
p := som3/m0_r3/pa7h-5/t0_/y0ur/file`
var substitution = ".../"
fmt.Println(re.ReplaceAllString(str, substitution))
}