using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^domaine\.com(?!\/$|\/subdomaine1).+$";
string input = @"domaine.com
domaine.com/
domaine.com/aaa
domaine.com/aasdasd/asdadas/aSD/
domaine.com/subdomaine1
domaine.com/subdomaine1/
domaine.com/subdomaine1/a
domaine.com/subdomaine1/aaaa/subdomaine1/
domaine.com/subdomaine2/aaaa/subdomaine1/";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}