$re = '/^domaine\.com(?!\/$|\/subdomaine1).+$/mi';
$str = 'domaine.com
domaine.com/
domaine.com/aaa
domaine.com/aasdasd/asdadas/aSD/
domaine.com/subdomaine1
domaine.com/subdomaine1/
domaine.com/subdomaine1/a
domaine.com/subdomaine1/aaaa/subdomaine1/
domaine.com/subdomaine2/aaaa/subdomaine1/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);