import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^domaine\\.com(?!\\/$|\\/subdomaine1).+$";
final String string = "domaine.com\n"
+ "domaine.com/\n"
+ "domaine.com/aaa\n"
+ "domaine.com/aasdasd/asdadas/aSD/\n"
+ "domaine.com/subdomaine1\n"
+ "domaine.com/subdomaine1/\n"
+ "domaine.com/subdomaine1/a\n"
+ "domaine.com/subdomaine1/aaaa/subdomaine1/\n"
+ "domaine.com/subdomaine2/aaaa/subdomaine1/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}