const regex = /^domaine\.com(?!\/$|\/subdomaine1).+$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^domaine\\.com(?!\\\/$|\\\/subdomaine1).+$', 'gmi')
const str = `domaine.com
domaine.com/
domaine.com/aaa
domaine.com/aasdasd/asdadas/aSD/
domaine.com/subdomaine1
domaine.com/subdomaine1/
domaine.com/subdomaine1/a
domaine.com/subdomaine1/aaaa/subdomaine1/
domaine.com/subdomaine2/aaaa/subdomaine1/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}