re = /^domaine\.com(?!\/$|\/subdomaine1).+$/mi
str = 'domaine.com
domaine.com/
domaine.com/aaa
domaine.com/aasdasd/asdadas/aSD/
domaine.com/subdomaine1
domaine.com/subdomaine1/
domaine.com/subdomaine1/a
domaine.com/subdomaine1/aaaa/subdomaine1/
domaine.com/subdomaine2/aaaa/subdomaine1/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end