using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<p><\/p>)+";
string input = @"<p></p>fsadfsafsa
<p></p>
<p>adfsafa</p>
<p>fdsafsafa</p>
<p></p>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}