import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<p><\\/p>)+";
final String string = "<p></p>fsadfsafsa\n"
+ "<p></p>\n"
+ "<p>adfsafa</p>\n"
+ "<p>fdsafsafa</p>\n"
+ "<p></p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}