re = /(<p><\/p>)+/
str = '<p></p>fsadfsafsa
<p></p>
<p>adfsafa</p>
<p>fdsafsafa</p>
<p></p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end