$re = '/(<p><\/p>)+/';
$str = '<p></p>fsadfsafsa
<p></p>
<p>adfsafa</p>
<p>fdsafsafa</p>
<p></p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);