#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z](?:\d[- ]*){14}$"
Local $sString = "D6101-40706-60905" & @CRLF & _
"D6101 40706 60905" & @CRLF & _
"D61014070660905" & @CRLF & _
"A1234 - 12345 - 12345" & @CRLF & _
"D6101 40706 609053" & @CRLF & _
"D6101070660905313"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")