$re = '/^[A-Z](?:\d[- ]*){14}$/m';
$str = 'D6101-40706-60905
D6101 40706 60905
D61014070660905
A1234 - 12345 - 12345
D6101 40706 609053
D6101070660905313';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);