package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z](?:\d[- ]*){14}$`)
var str = `D6101-40706-60905
D6101 40706 60905
D61014070660905
A1234 - 12345 - 12345
D6101 40706 609053
D6101070660905313`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}