use strict;
my $str = 'D6101-40706-60905
D6101 40706 60905
D61014070660905
A1234 - 12345 - 12345
D6101 40706 609053
D6101070660905313';
my $regex = qr/^[A-Z](?:\d[- ]*){14}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}