const regex = /^[A-Z](?:\d[- ]*){14}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z](?:\\d[- ]*){14}$', 'gm')
const str = `D6101-40706-60905
D6101 40706 60905
D61014070660905
A1234 - 12345 - 12345
D6101 40706 609053
D6101070660905313`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}