#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:https?:\/\/)?(?:www\.)?plus\.google\.com\/([\w]+\/)?([\d]\/)?([+]?[\w(\_\-)?p{L}]+|[\d]{21})(?:\/)?(?:[\w(\-\_)?]+)?"
Local $sString = "https://plus.google.com/+google/posts"" & @CRLF & _
" , "https://plus.google.com/+google/about"" & @CRLF & _
" , "https://plus.google.com/+google/photos"" & @CRLF & _
" , "https://plus.google.com/+google/videos"" & @CRLF & _
" , "https://plus.google.com/+google/plusones"" & @CRLF & _
" , "https://plus.google.com/+google/reviews"" & @CRLF & _
" , "https://plus.google.com/asdasda/104645458102703754878"" & @CRLF & _
" , "https://plus.google.com/u/0/LONGIDHE-RE"" & @CRLF & _
" , "https://plus.google.com/u/0/+JoseManuelGarcĂa_ertatto"" & @CRLF & _
"https://plus.google.com/b/101789019230490914475/101789019230490914475/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")