import Foundation
let pattern = #"(?:https?:\/\/)?(?:www\.)?plus\.google\.com\/([\w]+\/)?([\d]\/)?([+]?[\w(\_\-)?p{L}]+|[\d]{21})(?:\/)?(?:[\w(\-\_)?]+)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
https://plus.google.com/+google/posts"
, "https://plus.google.com/+google/about"
, "https://plus.google.com/+google/photos"
, "https://plus.google.com/+google/videos"
, "https://plus.google.com/+google/plusones"
, "https://plus.google.com/+google/reviews"
, "https://plus.google.com/asdasda/104645458102703754878"
, "https://plus.google.com/u/0/LONGIDHE-RE"
, "https://plus.google.com/u/0/+JoseManuelGarcĂa_ertatto"
https://plus.google.com/b/101789019230490914475/101789019230490914475/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)