// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?:https?:\/\/)?(?:www\.)?plus\.google\.com\/([\w]+\/)?([\d]\/)?([+]?[\w(\_\-)?p{L}]+|[\d]{21})(?:\/)?(?:[\w(\-\_)?]+)?").unwrap();
let string = "https://plus.google.com/+google/posts\"
, \"https://plus.google.com/+google/about\"
, \"https://plus.google.com/+google/photos\"
, \"https://plus.google.com/+google/videos\"
, \"https://plus.google.com/+google/plusones\"
, \"https://plus.google.com/+google/reviews\"
, \"https://plus.google.com/asdasda/104645458102703754878\"
, \"https://plus.google.com/u/0/LONGIDHE-RE\"
, \"https://plus.google.com/u/0/+JoseManuelGarcĂa_ertatto\"
https://plus.google.com/b/101789019230490914475/101789019230490914475/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}