use strict;
my $str = 'https://plus.google.com/+google/posts"
, "https://plus.google.com/+google/about"
, "https://plus.google.com/+google/photos"
, "https://plus.google.com/+google/videos"
, "https://plus.google.com/+google/plusones"
, "https://plus.google.com/+google/reviews"
, "https://plus.google.com/asdasda/104645458102703754878"
, "https://plus.google.com/u/0/LONGIDHE-RE"
, "https://plus.google.com/u/0/+JoseManuelGarcĂa_ertatto"
https://plus.google.com/b/101789019230490914475/101789019230490914475/';
my $regex = qr/(?:https?:\/\/)?(?:www\.)?plus\.google\.com\/([\w]+\/)?([\d]\/)?([+]?[\w(\_\-)?p{L}]+|[\d]{21})(?:\/)?(?:[\w(\-\_)?]+)?/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}